Out-of-bounds Write Affecting cups package, versions <2.4.7-r0


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.64% (50th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-WOLFILATEST-CUPS-5926677
  • published30 Sept 2023
  • disclosed21 Sept 2023

Introduced: 21 Sep 2023

CVE-2023-4504  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Wolfi cups to version 2.4.7-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream cups package and not the cups package as distributed by Wolfi. See How to fix? for Wolfi relevant fixed versions and status.

Due to failure in validating the length provided by an attacker-crafted PPD PostScript document, CUPS and libppd are susceptible to a heap-based buffer overflow and possibly code execution. This issue has been fixed in CUPS version 2.4.7, released in September of 2023.

CVSS Base Scores

version 3.1