Integer Overflow or Wraparound Affecting ffmpeg-8.1 package, versions <8.1.3-r0


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.14% (4th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-WOLFILATEST-FFMPEG81-21756980
  • published27 Oct 2026
  • disclosed6 Aug 2026

Introduced: 6 Aug 2026

CVE-2026-70628  (opens in a new tab)
CWE-190  (opens in a new tab)
CWE-787  (opens in a new tab)

How to fix?

Upgrade Wolfi ffmpeg-8.1 to version 8.1.3-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ffmpeg-8.1 package and not the ffmpeg-8.1 package as distributed by Wolfi. See How to fix? for Wolfi relevant fixed versions and status.

FFmpeg versions from 0.5 up to, but not including, 9.0 contain a signed integer overflow vulnerability in the DVB subtitle parser in libavcodec/dvbsub_parser.c that allows attackers to trigger a heap buffer overflow by supplying a crafted WTV file. The overflow causes the bounds-check guard expression to wrap to INT_MIN, bypassing the PARSE_BUF_SIZE comparison and invoking memcpy() with attacker-controlled data into a heap buffer, resulting in an out-of-bounds heap write and potential memory corruption or code execution.

CVSS Base Scores

version 3.1