Access of Resource Using Incompatible Type ('Type Confusion') Affecting gitaly-18.6 package, versions <18.6.6-r9


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.26% (17th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-WOLFILATEST-GITALY186-16336867
  • published1 May 2026
  • disclosed8 Apr 2026

Introduced: 8 Apr 2026

CVE-2026-27144  (opens in a new tab)
CWE-843  (opens in a new tab)

How to fix?

Upgrade Wolfi gitaly-18.6 to version 18.6.6-r9 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gitaly-18.6 package and not the gitaly-18.6 package as distributed by Wolfi. See How to fix? for Wolfi relevant fixed versions and status.

The compiler is meant to unwrap pointers which are the operands of a memory move; a no-op interface conversion prevented the compiler from making the correct determination about non-overlapping moves, potentially leading to memory corruption at runtime.

CVSS Base Scores

version 3.1