Stack-based Buffer Overflow Affecting gnupg package, versions <2.4.9-r10


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.44% (38th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-WOLFILATEST-GNUPG-18792100
  • published14 Aug 2026
  • disclosed27 Jan 2026

Introduced: 27 Jan 2026

CVE-2026-24882  (opens in a new tab)
CWE-121  (opens in a new tab)

How to fix?

Upgrade Wolfi gnupg to version 2.4.9-r10 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream gnupg package and not the gnupg package as distributed by Wolfi. See How to fix? for Wolfi relevant fixed versions and status.

In GnuPG before 2.5.17, a stack-based buffer overflow exists in tpm2daemon during handling of the PKDECRYPT command for TPM-backed RSA and ECC keys.

CVSS Base Scores

version 3.1