Information Exposure Affecting jruby-9.4 package, versions <9.4.15.0-r4


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.56% (45th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-WOLFILATEST-JRUBY94-18741147
  • published12 Aug 2026
  • disclosed30 Dec 2025

Introduced: 30 Dec 2025

CVE-2025-61594  (opens in a new tab)
CWE-200  (opens in a new tab)
CWE-212  (opens in a new tab)

How to fix?

Upgrade Wolfi jruby-9.4 to version 9.4.15.0-r4 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream jruby-9.4 package and not the jruby-9.4 package as distributed by Wolfi. See How to fix? for Wolfi relevant fixed versions and status.

URI is a module providing classes to handle Uniform Resource Identifiers. In versions 0.12.4 and earlier (bundled in Ruby 3.2 series) 0.13.2 and earlier (bundled in Ruby 3.3 series), 1.0.3 and earlier (bundled in Ruby 3.4 series), when using the + operator to combine URIs, sensitive information like passwords from the original URI can be leaked, violating RFC3986 and making applications vulnerable to credential exposure. This is a a bypass for the fix to CVE-2025-27221 that can expose user credentials. This issue has been fixed in versions 0.12.5, 0.13.3 and 1.0.4.

CVSS Base Scores

version 3.1