Uncontrolled Memory Allocation Affecting libssh package, versions <0.12.1-r0


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.57% (45th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-WOLFILATEST-LIBSSH-18741167
  • published12 Aug 2026
  • disclosed21 Jul 2026

Introduced: 21 Jul 2026

CVE-2026-59844  (opens in a new tab)
CWE-789  (opens in a new tab)

How to fix?

Upgrade Wolfi libssh to version 0.12.1-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libssh package and not the libssh package as distributed by Wolfi. See How to fix? for Wolfi relevant fixed versions and status.

A flaw was found in libssh. A remote authenticated client can issue SSH_FXP_READ requests with an arbitrarily large length, causing a libssh SFTP server to allocate excessive memory and potentially exhaust it through repeated requests.

CVSS Base Scores

version 3.1