Use After Free Affecting libssh package, versions <0.12.1-r0


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.35% (26th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-WOLFILATEST-LIBSSH-18741191
  • published12 Aug 2026
  • disclosed21 Jul 2026

Introduced: 21 Jul 2026

CVE-2026-59850  (opens in a new tab)
CWE-416  (opens in a new tab)

How to fix?

Upgrade Wolfi libssh to version 0.12.1-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream libssh package and not the libssh package as distributed by Wolfi. See How to fix? for Wolfi relevant fixed versions and status.

A flaw was found in libssh. If data packets are processed after a channel is closed, channel data callbacks can be invoked after the associated data has already been freed, leading to crashes or possible use-after-free conditions.

CVSS Base Scores

version 3.1