Heap-based Buffer Overflow Affecting mariadb-11.8 package, versions <11.8.9-r1


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

Exploit Maturity
Proof of Concept
EPSS
0.87% (59th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-WOLFILATEST-MARIADB118-19827855
  • published15 Sept 2026
  • disclosed20 Mar 2026

Introduced: 20 Mar 2026

CVE-2026-32710  (opens in a new tab)
CWE-122  (opens in a new tab)

How to fix?

Upgrade Wolfi mariadb-11.8 to version 11.8.9-r1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream mariadb-11.8 package and not the mariadb-11.8 package as distributed by Wolfi. See How to fix? for Wolfi relevant fixed versions and status.

MariaDB server is a community developed fork of MySQL server. An authenticated user can crash MariaDB versions 11.4 before 11.4.10 and 11.8 before 11.8.6 via a bug in JSON_SCHEMA_VALID() function. Under certain conditions it might be possible to turn the crash into a remote code execution. These conditions require tight control over memory layout which is generally only attainable in a lab environment. This issue is fixed in MariaDB 11.4.10, MariaDB 11.8.6, and MariaDB 12.2.2.

CVSS Base Scores

version 3.1