Resource Exhaustion Affecting modsecurity package, versions <3.0.9-r0


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.73% (50th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-WOLFILATEST-MODSECURITY-5846892
  • published21 Aug 2023
  • disclosed28 Apr 2023

Introduced: 28 Apr 2023

CVE-2023-28882  (opens in a new tab)
CWE-400  (opens in a new tab)

How to fix?

Upgrade Wolfi modsecurity to version 3.0.9-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream modsecurity package and not the modsecurity package as distributed by Wolfi. See How to fix? for Wolfi relevant fixed versions and status.

Trustwave ModSecurity 3.0.5 through 3.0.8 before 3.0.9 allows a denial of service (worker crash and unresponsiveness) because some inputs cause a segfault in the Transaction class for some configurations.

CVSS Base Scores

version 3.1