Incorrect Authorization Affecting net-kourier-1.21 package, versions <1.21.0-r6


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.66% (50th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-WOLFILATEST-NETKOURIER121-16133810
  • published23 Apr 2026
  • disclosed8 Apr 2026

Introduced: 8 Apr 2026

CVE-2026-27140  (opens in a new tab)
CWE-863  (opens in a new tab)

How to fix?

Upgrade Wolfi net-kourier-1.21 to version 1.21.0-r6 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream net-kourier-1.21 package and not the net-kourier-1.21 package as distributed by Wolfi. See How to fix? for Wolfi relevant fixed versions and status.

SWIG file names containing 'cgo' and well-crafted payloads could lead to code smuggling and arbitrary code execution at build time due to trust layer bypass.

CVSS Base Scores

version 3.1