Authentication Bypass Affecting opentelemetry-operator package, versions <0.154.0-r0


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
9.27% (96th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-WOLFILATEST-OPENTELEMETRYOPERATOR-17807950
  • published3 Jul 2026
  • disclosed31 Mar 2026

Introduced: 31 Mar 2026

CVE-2026-34040  (opens in a new tab)
CWE-288  (opens in a new tab)

How to fix?

Upgrade Wolfi opentelemetry-operator to version 0.154.0-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream opentelemetry-operator package and not the opentelemetry-operator package as distributed by Wolfi. See How to fix? for Wolfi relevant fixed versions and status.

Moby is an open source container framework. Prior to version 29.3.1, a security vulnerability has been detected that allows attackers to bypass authorization plugins (AuthZ). This issue has been patched in version 29.3.1.

CVSS Base Scores

version 3.1