Out-of-bounds Read Affecting qemu package, versions <11.0.1-r0


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.66% (49th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-WOLFILATEST-QEMU-17671701
  • published29 Jun 2026
  • disclosed5 Jul 2024

Introduced: 5 Jul 2024

CVE-2024-6505  (opens in a new tab)
CWE-125  (opens in a new tab)

How to fix?

Upgrade Wolfi qemu to version 11.0.1-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream qemu package and not the qemu package as distributed by Wolfi. See How to fix? for Wolfi relevant fixed versions and status.

A flaw was found in the virtio-net device in QEMU. When enabling the RSS feature on the virtio-net network card, the indirections_table data within RSS becomes controllable. Setting excessively large values may cause an index out-of-bounds issue, potentially resulting in heap overflow access. This flaw allows a privileged user in the guest to crash the QEMU process on the host.

CVSS Base Scores

version 3.1