Reachable Assertion Affecting qemu package, versions <11.0.1-r0


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.29% (21st percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-WOLFILATEST-QEMU-17671747
  • published29 Jun 2026
  • disclosed19 Sept 2024

Introduced: 19 Sep 2024

CVE-2024-8354  (opens in a new tab)
CWE-617  (opens in a new tab)

How to fix?

Upgrade Wolfi qemu to version 11.0.1-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream qemu package and not the qemu package as distributed by Wolfi. See How to fix? for Wolfi relevant fixed versions and status.

A flaw was found in QEMU. An assertion failure was present in the usb_ep_get() function in hw/net/core.c when trying to get the USB endpoint from a USB device. This flaw may allow a malicious unprivileged guest user to crash the QEMU process on the host and cause a denial of service condition.

CVSS Base Scores

version 3.1