Out-of-bounds Read Affecting rpm-sequoia package, versions <1.10.1-r10


Severity

Recommended
0.0
critical
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.29% (20th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-WOLFILATEST-RPMSEQUOIA-16188047
  • published24 Apr 2026
  • disclosed24 Apr 2026

Introduced: 24 Apr 2026

CVE-2026-41677  (opens in a new tab)
CWE-125  (opens in a new tab)
CWE-1284  (opens in a new tab)

How to fix?

Upgrade Wolfi rpm-sequoia to version 1.10.1-r10 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream rpm-sequoia package and not the rpm-sequoia package as distributed by Wolfi. See How to fix? for Wolfi relevant fixed versions and status.

rust-openssl provides OpenSSL bindings for the Rust programming language. From 0.9.0 to before 0.10.78, the *_from_pem_callback APIs did not validate the length returned by the user's callback. A password callback that returns a value larger than the buffer it was given can cause some versions of OpenSSL to over-read this buffer. OpenSSL 3.x is not affected by this. This vulnerability is fixed in 0.10.78.

CVSS Base Scores

version 3.1