CVE-2024-26141 Affecting ruby3.2-rack-2.2 package, versions <2.2.8.1-r0


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
1.61% (73rd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-WOLFILATEST-RUBY32RACK22-6422192
  • published12 Mar 2024
  • disclosed29 Feb 2024

Introduced: 29 Feb 2024

CVE-2024-26141  (opens in a new tab)

How to fix?

Upgrade Wolfi ruby3.2-rack-2.2 to version 2.2.8.1-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby3.2-rack-2.2 package and not the ruby3.2-rack-2.2 package as distributed by Wolfi. See How to fix? for Wolfi relevant fixed versions and status.

Rack is a modular Ruby web server interface. Carefully crafted Range headers can cause a server to respond with an unexpectedly large response. Responding with such large responses could lead to a denial of service issue. Vulnerable applications will use the Rack::File middleware or the Rack::Utils.byte_ranges methods (this includes Rails applications). The vulnerability is fixed in 3.0.9.1 and 2.2.8.1.

CVSS Base Scores

version 3.1