Improper Cross-boundary Removal of Sensitive Data Affecting ruby3.2-uri package, versions <1.0.3-r0


Severity

Recommended
0.0
medium
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.51% (42nd percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-WOLFILATEST-RUBY32URI-15412419
  • published5 Mar 2026
  • disclosed4 Mar 2025

Introduced: 4 Mar 2025

CVE-2025-27221  (opens in a new tab)
CWE-212  (opens in a new tab)

How to fix?

Upgrade Wolfi ruby3.2-uri to version 1.0.3-r0 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ruby3.2-uri package and not the ruby3.2-uri package as distributed by Wolfi. See How to fix? for Wolfi relevant fixed versions and status.

In the URI gem before 1.0.3 for Ruby, the URI handling methods (URI.join, URI#merge, URI#+) have an inadvertent leakage of authentication credentials because userinfo is retained even after changing the host.

CVSS Base Scores

version 3.1