Uncontrolled Recursion Affecting ts-patch package, versions <4.0.1-r48


Severity

Recommended
0.0
high
0
10

Snyk's Security Team recommends NVD's CVSS assessment. Learn more

Threat Intelligence

EPSS
0.76% (54th percentile)

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk IDSNYK-WOLFILATEST-TSPATCH-21692457
  • published24 Oct 2026
  • disclosed18 Sept 2026

Introduced: 18 Sep 2026

CVE-2026-93687  (opens in a new tab)
CWE-674  (opens in a new tab)

How to fix?

Upgrade Wolfi ts-patch to version 4.0.1-r48 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream ts-patch package and not the ts-patch package as distributed by Wolfi. See How to fix? for Wolfi relevant fixed versions and status.

braces through 3.0.3 contains a stack overflow vulnerability in the recursive AST walkers that lack depth guards. Attackers can supply deeply nested brace patterns under the character limit to exhaust the call stack and terminate the Node.js process with an uncaught RangeError.

CVSS Base Scores

version 3.1