HTML Injection Affecting ag-grid Open this link in a new tab package, versions >=3.3.0 <5.0.0-alpha.0


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    npm:ag-grid:20160519

  • published

    16 Mar 2017

  • disclosed

    18 May 2016

  • credit

    Theodore Brown

Introduced: 18 May 2016

CWE-80 Open this link in a new tab

Overview

ag-grid is an advanced Data Grid / Data Table supporting Javascript / React / AngularJS / Web Components.

Affected versions of the package are vulnerable to HTML Injection. ag-grid used mozilla's Element.innerHTML, which is vulnerable to Cross-site Scripting (XSS) attacks when used within a user-inputted value. In this case an attacker could insert a malicious username and initiate a XSS attack, like:

<span onclick="alert('hacked!')">John Smith</span>

Remediation

Upgrade ag-grid to version 5.0.0 or higher.