Cross-site Request Forgery (CSRF) Affecting auth0-lock package, versions <11.0.0



    Attack Complexity Low

    Threat Intelligence

    EPSS 0.07% (29th percentile)
Expand this section
8.8 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID npm:auth0-lock:20180409
  • published 9 Apr 2018
  • disclosed 4 Apr 2018
  • credit Unknown

How to fix?

Upgrade auth0-lock to version 11.0.0 or higher.


auth0-lock is an authentication broker that supports both social and enterprise identity providers, including Active Directory, LDAP, Google Apps, and Salesforce.

Affected versions of this package are vulnerable to Cross-Site Request Forgery (CSRF) attacks if the Legacy Lock API flag is enabled.

Once the user credentials are verified, an HTML form is rendered into the user’s browser. A JSON Web Token (JWT) is POSTed to the /login/callback endpoint, and it maintains state regarding the identity of the user. Due to the lack of session binding, this form post is susceptible to CSRF. An attacker with valid user credentials at an Auth0 tenant can use them to gain such a form, and then employ techniques such as social engineering or clickjacking to have a victim’s browser execute it.