Insecure Hashing Algorithm Affecting contwidgetor Open this link in a new tab package, versions *


0.0
low
  • Exploit Maturity

    Mature

  • Attack Complexity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    npm:contwidgetor:20170303

  • published

    28 Jun 2017

  • disclosed

    2 Mar 2017

  • credit

    Liang Gong

Introduced: 2 Mar 2017

CWE-916 Open this link in a new tab
First added by Snyk

How to fix?

There is no fix version for contwidgetor.

Overview

contwidgetor is a contributions widget for both bitbucket and github.

Affected versions of the package use the insecure SHA-1 in the authentication method. It is possible to duplicate the hash and should not be used in security sensitive instances.