Cross-site Scripting (XSS) Affecting cordova-android package, versions <3.5.1



    Attack Complexity Low

    Threat Intelligence

    EPSS 0.94% (83rd percentile)
Expand this section
6.5 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID npm:cordova-android:20140804
  • published 21 Jun 2017
  • disclosed 3 Aug 2014
  • credit David Kaplan, Roee Hay

How to fix?

Upgrade cordova-android to version 3.5.1 or higher.


cordova-android is an Android application library that allows for Cordova-based projects to be built for the Android Platform.

Affected versions of the package are vulnerable to Cross-Application Scripting. This allows remote attackers to change the start page via a crafted intent URL.