Arbitrary execution Affecting cordova-ios package, versions >=3.5.0 <4.0.0



    Attack Complexity Low
    User Interaction Required

    Threat Intelligence

    EPSS 0.45% (75th percentile)
Expand this section
4.4 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID npm:cordova-ios:20141024
  • published 21 Jun 2017
  • disclosed 23 Oct 2014
  • credit Ian Clelland

How to fix?

Upgrade cordova-ios to version 4.0.0 or higher.


cordova-ios is an iOS application library that allows for Cordova-based projects to be built for the iOS Platform.

Affected versions of the package are vulnerable to Arbitrary Code Execution. A malicious plugin can be executed when a user clicks on a link.