CRLF Injection Affecting cordova-plugin-file-transfer package, versions <1.3.0


0.0
medium

Snyk CVSS

    Attack Complexity Low
    User Interaction Required

    Threat Intelligence

    EPSS 0.34% (71st percentile)
Expand this section
NVD
4.3 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID npm:cordova-plugin-file-transfer:20150826
  • published 21 Jun 2017
  • disclosed 25 Aug 2015
  • credit Muneaki Nishimura

How to fix?

Upgrade cordova-plugin-file-transfer to version 1.3.0 or higher.

Overview

cordova-plugin-file-transfer is a Cordova File Transfer Plugin.

Affected versions of the package are vulnerable to CRLF Injection. This allows remote attackers to inject arbitrary headers via CRLF sequences in the filename of an uploaded file.