Insecure Defaults Affecting faye package, versions <0.8.9 >=0.5.0



    Attack Complexity Low
    User Interaction Required

    Threat Intelligence

    Exploit Maturity Proof of concept
    EPSS 0.85% (82nd percentile)
Expand this section
4.3 medium
Expand this section
3.7 low
Expand this section
Red Hat
4.3 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID npm:faye:20121107
  • published 28 Mar 2017
  • disclosed 6 Sep 2011
  • credit Thai Duong, Juliano Rizzo

How to fix?

Upgrade faye to version 0.8.9 or higher.


faye is a simple pub/sub messaging for the web. Affected versions of the package are vulnerable to Man-In-The-Middle attacks due to insecure defaults. By default, faye used an insecure cipher, allowing attackers to gain access to SSL encrypted packets. This attack is also known as the BEAST attack.

You can read more about insecure defaults on our blog