Resources Downloaded over Insecure Protocol Affecting gatsby-cli Open this link in a new tab package, versions <1.0.9


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    npm:gatsby-cli:20170202

  • published

    1 Mar 2018

  • disclosed

    1 Feb 2017

  • credit

    davidjb

Introduced: 1 Feb 2017

CWE-300 Open this link in a new tab

How to fix?

Upgrade gatsby-cli to version 1.0.9 or higher.

Overview

gatsby-cli is a command-line interface for creating new sites and running Gatsby commands.

Affected versions of the package are vulnerable to Resources Downloaded over Insecure Protocol due to downloading resources over an insecure protocol. It used the git:// protocol to clone repositories, which isn't safe as it is unencrypted. You can read more about Man-in-the-Middle (MitM) on our blog.

References