Open Redirect Affecting ghost Open this link in a new tab package, versions <0.10.0


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    npm:ghost:20160823

  • published

    30 May 2017

  • disclosed

    22 Aug 2016

  • credit

    Jesse Dijkstra

Introduced: 22 Aug 2016

CWE-601 Open this link in a new tab

How to fix?

Upgrade ghost to version 0.10.0 or higher.

Overview

ghost is a blogging platform. Affected versions of the package are vulnerable to Open Redirect attacks. A malicious user can create a link containing double slashes, which are treated as HTTP calls, and redirect to a site of their choosing.