Arbitrary Code Injection Affecting growl package, versions <1.10.0



    Attack Complexity Low
    Confidentiality High
    Integrity High
    Availability High

    Threat Intelligence

    EPSS 0.53% (77th percentile)
Expand this section
9.8 critical
Expand this section
Red Hat
8.1 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID npm:growl:20160721
  • published 1 May 2017
  • disclosed 21 Jul 2016
  • credit Cristian-Alexandru Staicu, Michael Pradel, Ben Livshits

How to fix?

Upgrade growl to version 1.10.0 or higher.


growl is a package adding Growl support for Nodejs.

Affected versions of this package are vulnerable to Arbitrary Code Injection due to unsafe use of the eval() function. Node.js provides the eval() function by default, and is used to translate strings into Javascript code. An attacker can craft a malicious payload to inject arbitrary commands.