Unsigned Request Headers Affecting http-signature package, versions <0.10.0 >=0.9.0


0.0
medium

Snyk CVSS

    Attack Complexity Low

    Threat Intelligence

    EPSS 0.08% (33rd percentile)
Expand this section
NVD
7.5 high
Expand this section
Red Hat
7.5 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID npm:http-signature:20130418
  • published 13 Feb 2017
  • disclosed 17 Apr 2013
  • credit Dave Longley

How to fix?

Upgrade http-signature to version 0.10.0 or higher.

Overview

http-signature is a Reference implementation of Joyent's HTTP Signature scheme. Affected versions of the package are vulnerable to header forgery, due to the header names not being signed. An attacker could switch the header list order and header value order ending up wit the same signature for two separate requests.