Resources Downloaded over Insecure Protocol Affecting install-nw package, versions <1.1.5


0.0
high

Snyk CVSS

    Attack Complexity High
    User Interaction Required
    Confidentiality High
    Integrity High
    Availability High

    Threat Intelligence

    EPSS 0.17% (53rd percentile)
Expand this section
NVD
8.1 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID npm:install-nw:20161104
  • published 4 Jan 2017
  • disclosed 4 Nov 2016
  • credit Adam Baldwin

How to fix?

Update to version 1.1.5 or greater.

Overview

install-nw is a module which quickly and robustly installs and caches NW.js.

Affected versions of the package are vulnerable to Man in the Middle (MitM) attacks due to downloading resources over an insecure protocol. Without a secure connection, it is possible for an attacker to intercept this connection and alter the packages received. In serious cases, this may even lead to Remote Code Execution (RCE) on your host server.

References