LDAP Injection Affecting ldapauth Open this link in a new tab package, versions <=2.2.4


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    npm:ldapauth:20150918

  • published

    18 Sep 2015

  • disclosed

    18 Sep 2015

  • credit

    David Black, Jerome Touffe-Blin

Introduced: 18 Sep 2015

CWE-90 Open this link in a new tab

How to fix?

Consider updating to use ldapauth-fork 2.3.3 or greater as ldapauth has not yet been patched.

Overview

ldapauth versions <= 2.2.4 are vulnerable to ldap injection through the username parameter.

Source: Node Security Project