Potential Command Injection Affecting libnotify package, versions <= 1.0.3


0.0
high

Snyk CVSS

    Attack Complexity Low
    User Interaction Required
    Confidentiality High

    Threat Intelligence

    EPSS 0.32% (70th percentile)
Expand this section
NVD
9.8 critical

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID npm:libnotify:20130515
  • published 15 May 2013
  • disclosed 15 May 2013
  • credit Adam Baldwin

Overview

Untrusted input passed in the call to libnotify.notify could result in execution of shell commands. Callers may be unaware of this.

Source: Node Security Project

Details

Example:

var libnotify = require('libnotify')
libnotify.notify('UNTRUSTED INPUT', { title: \"\" }, function () {
    console.log(arguments);
})

References

Special thanks to Neal Poole for submitting the pull request to fix this issue.