Arbitrary Code Execution Affecting mathjs package, versions <3.17.0


0.0
high

Snyk CVSS

    Attack Complexity Low

    Threat Intelligence

    EPSS 0.32% (70th percentile)
Expand this section
NVD
9.8 critical

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID npm:mathjs:20171118
  • published 28 Nov 2017
  • disclosed 18 Nov 2017
  • credit Masato Kinugawa

How to fix?

Upgrade mathjs to version 3.17.0 or higher.

Overview

mathjs is an extensive math library for JavaScript and Node.js

Affected versions of the package are vulnerable to Arbitrary Code Execution via typed-function. A malicious user could possibly execute arbitrary code in the JavaScript engine, by creating a typed function with JavaScript code in the name.