Denial of Service (DoS) Affecting mongoose Open this link in a new tab package, versions >=4.0.0 <4.1.10


0.0
high
  • Attack Complexity

    Low

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    npm:mongoose:20150925

  • published

    13 Dec 2016

  • disclosed

    24 Sep 2015

  • credit

    andiris29

Introduced: 24 Sep 2015

CWE-400 Open this link in a new tab

How to fix?

Upgrade mongoose to version 4.1.10 or higher.

Overview

mongoose is a MongoDB ODM. Affected versions of the package are vulnerable to Denial of Service (DoS) via Infinite Loop when calculating a corrupt array. An attacker can use this to his advantage to crash the servers.

Details

Denial of Service (DoS) describes a family of attacks, all aimed at making a system inaccessible to its intended and legitimate users.

Unlike other vulnerabilities, DoS attacks usually do not aim at breaching security. Rather, they are focused on making websites and services unavailable to genuine users resulting in downtime.

One popular Denial of Service vulnerability is DDoS (a Distributed Denial of Service), an attack that attempts to clog network pipes to the system by generating a large volume of traffic from many machines.

When it comes to open source libraries, DoS vulnerabilities allow attackers to trigger such a crash or crippling of the service by using a flaw either in the application code or from the use of open source libraries.

Two common types of DoS vulnerabilities:

  • High CPU/Memory Consumption- An attacker sending crafted requests that could cause the system to take a disproportionate amount of time to process. For example, commons-fileupload:commons-fileupload.

  • Crash - An attacker sending crafted requests that could cause the system to crash. For Example, npm ws package