Arbitrary Code Injection Affecting mongoosify Open this link in a new tab package, versions <0.0.4


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    npm:mongoosify:20160408

  • published

    1 May 2017

  • disclosed

    8 Apr 2016

  • credit

    Cristian-Alexandru Staicu, Michael Pradel, Ben Livshits

Introduced: 8 Apr 2016

CWE-94 Open this link in a new tab

How to fix?

Upgrade mongoosify to version 0.0.4 or higher.

Overview

mongoosify is a prototype-based inheritance library that makes it easy to create objects and inheritance hierarchies without losing the power of javascript's prototype system.

Affected versions of the package are vulnerable to Arbitrary Code Injection due to unsafe use of the eval() function. Node.js provides the eval() function by default, and is used to translate strings into Javascript code. An attacker can craft a malicious payload to inject arbitrary commands.