Access Restriction Bypass Affecting npm Open this link in a new tab package, versions <5.7.1


0.0
medium
  • Attack Complexity

    Low

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    npm:npm:20180222

  • published

    21 Mar 2018

  • disclosed

    22 Feb 2018

  • credit

    Unknown

How to fix?

Upgrade npm to version 5.7.1 or higher.

Overview

npm is a package manager for JavaScript.

Affected versions of this package are vulnerable to Access Restriction Bypass. It might allow local users to bypass intended filesystem access restrictions due to ownerships of /etc and /usr directories are being changed unexpectedly, related to a "correctMkdir" issue.