User Impersonation Affecting passport-wsfed-saml2 package, versions <3.0.5



    Attack Complexity Low
    Integrity High

    Threat Intelligence

    EPSS 0.22% (60th percentile)
Expand this section
8.1 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID npm:passport-wsfed-saml2:20171222
  • published 3 Jan 2018
  • disclosed 22 Dec 2017
  • credit Alan Bishop

How to fix?

Upgrade passport-wsfed-saml2 to version 3.0.5 or higher.


passport-wsfed-saml2 is a ws-federation protocol + SAML2 tokens authentication provider for Passport.

Affected versons if thus package are vulnerable to User Impersonation. A vulnerability has been discovered in the Auth0 passport-wsfed-saml2 library affecting versions < 3.0.5. This vulnerability allows an attacker to impersonate another user and potentially elevate their privileges if the SAML identity provider does not sign the full SAML response (e.g., only signs the assertion within the response).