Arbitrary Code Execution Affecting quill package, versions >=1.0.0-beta.0 <1.0.4



    Attack Complexity Low
    User Interaction Required

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID npm:quill:20160916
  • published 28 Feb 2017
  • disclosed 15 Sep 2016
  • credit Sajjad Hashemian

Introduced: 15 Sep 2016

CVE NOT AVAILABLE CWE-94 Open this link in a new tab

How to fix?

Upgrade quill to version 1.0.4 or higher.


quill is powerful, rich text editor. Affected versions of the package are vulnerable to Arbitrary Code Execution due to not sanitizing user input when in the pasteHTML() function. The function was renamed, deprecated and was set to be removed in version 2.0.0.

var quill = new Quill('#editor', {
  theme: 'snow'

quill.pasteHTML('<img src=// onerror="alert(&#39;Not Found!&#39;)">');