Broken CORS Affecting sails package, versions <0.12.7


0.0
high

Snyk CVSS

    Attack Complexity Low
    Confidentiality High

    Threat Intelligence

    EPSS 0.07% (29th percentile)
Expand this section
NVD
4.4 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID npm:sails:20161013
  • published 20 Oct 2016
  • disclosed 13 Oct 2016
  • credit Evan Johnson

How to fix?

Upgrade sails to version 0.12.7 or higher.

Overview

sails is API-driven framework for building realtime apps, using MVC conventions (based on Express and Socket.io).

Sails version 0.12.6 and lower allowed the default CORS settings to be very permissive, letting the attacker to bypass the Same Origin Policy.