SQL Injection Affecting sequelize package, versions <3.20.0


0.0
medium
  • Attack Complexity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    npm:sequelize:20160329

  • published

    1 Apr 2016

  • disclosed

    29 Mar 2016

  • credit

    Unknown

How to fix?

Upgrade to version 3.20.0 or greater.

Overview

sequelize versions prior to 3.20.0 improperly escape arrays of strings bound to named parameters.