Arbitrary Code Execution Affecting static-eval package, versions <2.0.0


0.0
high

Snyk CVSS

    Attack Complexity Low

    Threat Intelligence

    Exploit Maturity Mature
    EPSS 1.55% (87th percentile)
Expand this section
NVD
9.8 critical

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID npm:static-eval:20171016
  • published 18 Oct 2017
  • disclosed 16 Oct 2017
  • credit Matt Austin

How to fix?

Upgrade static-eval to version 2.0.0 or higher.

Overview

static-eval is a module to evaluate statically-analyzable expressions.

Affected versions of the package are vulnerable to Arbitrary Code Execution. If un-sanitized user input is passed to static-eval, it is possible to break out of the sandboxed instance, and execute arbitrary code from the standard library.