Man-in-the-Middle (MitM) Affecting tiny-json-http package, versions <7.0.0


0.0
medium

Snyk CVSS

    Attack Complexity Low

    Threat Intelligence

    EPSS 0.11% (43rd percentile)
Expand this section
NVD
8.1 high

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID npm:tiny-json-http:20180214
  • published 15 Mar 2018
  • disclosed 14 Feb 2018
  • credit Unknown

How to fix?

Upgrade tiny-json-http to version 7.0.0 or higher.

Overview

tiny-json-http is a minimalist HTTP client for GET and POSTing JSON payloads.

Affected versions of this package are vulnerable to Man-in-the-Middle (MitM) attacks. It contains a Missing SSL certificate validation vulnerability in The libraries core functionality is affected. that can result in Exposes the user to man-in-the-middle attacks.