SQL Injection Affecting waterline-sequel package, versions <0.5.1


0.0
high

Snyk CVSS

    Attack Complexity Low
    Confidentiality High

    Threat Intelligence

    EPSS 0.51% (76th percentile)
Expand this section
NVD
9.8 critical

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID npm:waterline-sequel:20160804
  • published 31 Oct 2016
  • disclosed 4 Aug 2016
  • credit James Hush

How to fix?

Upgrade waterline-sequel to version 0.5.1 or greater

Overview

'waterline-sequel' is a helper library for generating SQL queries from the Waterline Query Language.

waterline-sequel version 0.5.0 is vulnerable to SQL Injection via like, contains, startsWith or endsWith methods.