github.com/grafana/grafana/pkg/api vulnerabilities

Direct Vulnerabilities

Known vulnerabilities in the github.com/grafana/grafana/pkg/api package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • H
Improper Authentication

>=5.3.0 <8.3.10 >=8.4.0 <8.4.10 >=8.5.0 <8.5.9 >=9.0.0 <9.0.3
  • M
Information Exposure

>=0.0.0
  • M
Cross-site Request Forgery (CSRF)

<7.5.15 >=8.0.0 <8.3.5
  • M
Information Exposure

<7.5.15 >=8.0.0 <8.3.5
  • M
Directory Traversal

>=5.0.0 <7.5.12 >=8.0.0 <8.3.2
  • H
Directory Traversal

>=8.0.0 <8.0.7 >=8.1.0 <8.1.8 >=8.2.0 <8.2.7 >=8.3.0 <8.3.1
  • C
Authentication Bypass

>=8.0.0 <8.1.6 >=2.0.1 <7.5.11
  • H
Authentication Bypass

<4.6.4 >=5.0.0 <5.2.3