Authentication Bypass Affecting github.com/grafana/grafana/pkg/api package, versions <4.6.4 >=5.0.0 <5.2.3


0.0
high
  • Attack Complexity

    High

  • Confidentiality

    High

  • Integrity

    High

  • Availability

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-GOLANG-GITHUBCOMGRAFANAGRAFANAPKGAPI-50087

  • published

    2 Sep 2018

  • disclosed

    19 Aug 2018

  • credit

    Unknown

How to fix?

Upgrade github.com/grafana/grafana/pkg/api to version 4.6.4, 5.2.3 or higher.

Overview

github.com/grafana/grafana/pkg/api is a tool for monitoring and metric analytics & dashboards for Graphite, InfluxDB & Prometheus & More.

Affected versions of the package are vulnerable to Authentication Bypass. An attacker could generate a valid cookie knowing only a username of an LDAP or OAuth user.