grub2-i386-pc vulnerabilities

Direct Vulnerabilities

Known vulnerabilities in the grub2-i386-pc package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • M
Out-of-bounds Write

<2.04-150200.9.68.1
  • M
Out-of-bounds Write

<2.04-150200.9.68.1
  • H
CVE-2022-28736

<2.04-150200.9.63.2
  • H
CVE-2022-28735

<2.04-150200.9.63.2
  • H
CVE-2022-28734

<2.04-150200.9.63.2
  • H
CVE-2022-28733

<2.04-150200.9.63.2
  • H
Out-of-bounds Write

<2.04-150200.9.63.2
  • M
Out-of-bounds Write

<2.04-150200.9.63.2
  • H
Out-of-bounds Write

<2.04-150200.9.63.2
  • M
Integer Overflow or Wraparound

<2.04-9.7.1
  • M
Race Condition

<2.04-9.7.1
  • H
Race Condition

<2.04-9.7.1
  • M
Integer Overflow or Wraparound

<2.04-9.7.1
  • M
Out-of-bounds Write

<2.04-9.7.1
  • M
Integer Overflow or Wraparound

<2.04-9.7.1
  • H
Buffer Overflow

<2.04-9.7.1
  • H
Improper Verification of Cryptographic Signature

<2.04-9.15.1
  • H
Use After Free

<2.04-9.34.1
  • H
Out-of-bounds Write

<2.04-9.34.1
  • H
Out-of-bounds Write

<2.04-9.34.1
  • H
Improper Authorization

<2.04-9.34.1
  • H
Stack-based Buffer Overflow

<2.04-9.34.1
  • H
Out-of-bounds Write

<2.04-9.34.1
  • H
Incomplete Blacklist

<2.04-9.34.1
  • L
SUSE-SU-2021:1636-1

<2.04-9.45.2