Out-of-bounds Write Affecting grub2-i386-pc package, versions <2.04-150200.9.68.1


0.0
medium

Snyk CVSS

    Attack Complexity High
    Privileges Required High
    Confidentiality High
    Integrity High
    Availability High
Expand this section
NVD
8.6 high
Expand this section
Red Hat
8.2 high
Expand this section
SUSE
6.4 medium

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • Snyk ID SNYK-SLES152-GRUB2I386PC-3148192
  • published 26 Nov 2022
  • disclosed 25 Nov 2022

How to fix?

Upgrade SLES:15.2 grub2-i386-pc to version 2.04-150200.9.68.1 or higher.

NVD Description

Note: Versions mentioned in the description apply only to the upstream grub2-i386-pc package and not the grub2-i386-pc package as distributed by SLES:15.2. See How to fix? for SLES:15.2 relevant fixed versions and status.

A buffer overflow was found in grub_font_construct_glyph(). A malicious crafted pf2 font can lead to an overflow when calculating the max_glyph_size value, allocating a smaller than needed buffer for the glyph, this further leads to a buffer overflow and a heap based out-of-bounds write. An attacker may use this vulnerability to circumvent the secure boot mechanism.