org.bouncycastle:bcprov-jdk15to18 vulnerabilities

The Bouncy Castle Crypto package is a Java implementation of cryptographic algorithms. This jar contains JCE provider and lightweight API for the Bouncy Castle Cryptography APIs for JDK 1.5 to JDK 1.8.

  • latest version

    1.72

  • latest non vulnerable version

  • first published

    3 years ago

  • latest version published

    2 months ago

  • licenses detected

  • package manager

Direct Vulnerabilities

Known vulnerabilities in the org.bouncycastle:bcprov-jdk15to18 package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • M
Cryptographic Issues

[1.63,1.69)
  • M
Timing Attack

(,1.66)
  • H
Comparison Using Wrong Factors

[1.65,1.67)

Package versions

1 - 10 of 10 Results
version published direct vulnerabilities
1.72 29 Sep, 2022
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L
1.71 6 Apr, 2022
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L
1.70 1 Dec, 2021
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L
1.69 10 Jun, 2021
  • 0
    C
  • 0
    H
  • 0
    M
  • 0
    L
1.68 23 Dec, 2020
  • 0
    C
  • 0
    H
  • 1
    M
  • 0
    L
1.67 1 Nov, 2020
  • 0
    C
  • 0
    H
  • 1
    M
  • 0
    L
1.66 8 Jul, 2020
  • 0
    C
  • 1
    H
  • 1
    M
  • 0
    L
1.65 6 Apr, 2020
  • 0
    C
  • 1
    H
  • 2
    M
  • 0
    L
1.64 12 Oct, 2019
  • 0
    C
  • 0
    H
  • 2
    M
  • 0
    L
1.63 11 Sep, 2019
  • 0
    C
  • 0
    H
  • 2
    M
  • 0
    L