spree vulnerabilities

A complete open source e-commerce solution with multi-store, multi-currency and multi-language capabilities

Direct Vulnerabilities

Known vulnerabilities in the spree package. This does not include vulnerabilities belonging to this package’s dependencies.

Automatically find and fix vulnerabilities affecting your projects. Snyk scans for vulnerabilities and provides fixes for free.
Fix for free
Vulnerability Vulnerable Version
  • H
Denial of Service (DoS)

<4.2.0
  • H
Authentication Bypass

>=3.7.0, <3.7.11 >=4.0.0, <4.0.4 >=4.1.0, <4.1.11
  • M
Arbitrary Code Execution

>=2.5, <3.0.3 >=2.4, <2.4.9 >=2.3, <2.3.12 <2.2.13
  • M
Arbitrary Code Execution

>=2.5, <3.0.2 >=2.4, <2.4.8 >=2.3, <2.3.11 <2.2.12
  • M
Cross Site Request Forgery

>=2.5, <3.0.0.rc4 >=2.4, <2.4.5 >=2.3, <2.3.8 <2.2.10
  • M
Privilege Escalation

<1.1.6
  • M
Arbitrary Command Execution

<2.0.0
  • M
Cross-site Scripting (XSS)

>=1.1, <1.1.2 >=0.71, <1.0.5 >=0.12, <0.70.6 <0.11.4
  • M
Arbitrary Command Execution

>=1.1, <1.1.2 >=0.71, <1.0.5 >=0.12, <0.70.6 <0.11.4
  • H
Arbitrary Command Execution

<0.60.2
  • H
Arbitrary File Disclosure

<0.50.1
  • M
Information Exposure

>=0.12, <0.30.0 <0.11.2
  • M
Improperly Controlled Model Modification

<0.3.0
  • M
Cryptographic Protection Bypass

<0.3.0