Cross Site Request Forgery Affecting spree Open this link in a new tab package, versions < 3.0.0.rc4, >= 2.5 < 2.4.5, >= 2.4 < 2.3.8, >= 2.3 < 2.2.10


0.0
medium
  • Attack Complexity

    Low

  • User Interaction

    Required

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-RUBY-SPREE-20360

  • published

    4 Mar 2015

  • disclosed

    4 Mar 2015

  • credit

    Egor Homakov

Introduced: 4 Mar 2015

CWE-200 Open this link in a new tab

Overview

Spree is an open source e-commerce framework for Ruby on Rails.

Spree contains a flaw in the API as HTTP requests do not require multiple steps, explicit confirmation, or a unique token when performing certain sensitive actions. By tricking a user into following a specially crafted link, a context-dependent attacker can perform a Cross-site Request Forgery (CSRF / XSRF) attack causing the victim to disclose potentially sensitive information to attackers.