Authentication Bypass Affecting spree Open this link in a new tab package, versions >=3.7.0, <3.7.11 >=4.0.0, <4.0.4 >=4.1.0, <4.1.11


0.0
high
  • Attack Complexity

    Low

  • Integrity

    High

Do your applications use this vulnerable package?

In a few clicks we can analyze your entire application and see what components are vulnerable in your application, and suggest you quick fixes.

Test your applications
  • snyk-id

    SNYK-RUBY-SPREE-1020061

  • published

    21 Oct 2020

  • disclosed

    20 Oct 2020

  • credit

    Unknown

How to fix?

Upgrade spree to version 3.7.11, 4.0.4, 4.1.11 or higher.

Overview

Affected versions of this package are vulnerable to Authentication Bypass. The perpetrator who previously obtained an old expired user token could use it to access Storefront API v2 endpoints.

References